Ruger Talk Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Need help. Installed new Tandemkross trigger in my Mark IV. If I adjust the pre-travel any more, the trigger will not reset. Way too much take up. Any suggestions??
 

·
Registered
Joined
·
8,549 Posts
Does Tanderkross have a trouble question and answer area on their website? Have you checked to see if your MKIV is one of the guns that needs the safety recall performed on it or have you had it done already by Ruger?

Welcome to RT and your taking the time to use the introduction thread for new members would get you a good start into RT forum.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the input. And yes, I have sent the pistol in to Ruger for the recall. I didn't install the Tandemkross trigger until I got it back. I installed one in my S&W Victory and have been very pleased with it. Called & emailed Tandemkross and cannot get a response. Customer service seems to be lacking a bit.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Yes, it's the Mark IV trigger. Finally got ahold of Tandemkross and they recommend installing a volquartzen sear.
 

·
Registered
Joined
·
8,549 Posts
Is there a big noticeable difference in the trigger break over the stock trigger?
 

·
Registered
Joined
·
3,442 Posts
Is there something defective with the trigger? Did you possibly install it incorrectly?
 

·
Registered
Joined
·
3,442 Posts
Welcome to the forum, btw. And like Buster said, hop over to the intro section so we can all give you a proper welcome
 

·
Registered
Joined
·
2 Posts
@Plink, I just installed the TK trigger in my IV Lite.
It came with three bolts.
Green tip
Short
Long

I was told that short is for one version, and long is for the lite
 
1 - 10 of 10 Posts
Top