Ruger Talk Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I love my Rugers but my SR9c has a problem where once or twice in every 50 rounds, it cycles and feeds fine but fails to reset the trigger and striker. I found that others have had the same problem. Ruger suggested a good cleaning (mine get cleaned every time I use them) including removing the striker and cleaning it and the striker channel. Anyone had any experience with this problem?
 

· Registered
Joined
·
4 Posts
Discussion Starter · #4 · (Edited)
I do use some WWB but I like Federal. I have had this problem with Winchester, Fiocchi and Federal. I can't say that I have ever had any other problem with it. The gun is accurate and a pleasure to shoot. I have put about 700 rounds through it and it has been cleaned after every session (I'm fussy about that). There are no noticeable signs of wear and it does it with any magazine but usually only once or twice in 50 rounds. It did not start until after 250-300 rounds. I can shoot the same ammunition in my Glocks and never have a problem but I know that doesn't really mean anything.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Well, that's a good thought but it doesn't seem to have any regular pattern. The other day it happened after the third shot in the first mag and then again about 3 mags later. I will mark the mags and see if it always happens on the same mag. You're right about "throwing" the first shot. I have done that. Especially if I have been shooting something like my wife's P22. Thanks for the advice. I will pay closer attention to my grip and which mag I have in it. I knew you guys would be helpful!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top