SR762 and Gen 3 PMags

Discussion in 'Ruger Rifle Forum' started by Mac11, Dec 8, 2013.

  1. Mac11

    Mac11 New Member

    4
    0
    0
    Anybody out there having problems with the Gen 3 Pmags. There's a fellla on another forum selling his SR762 because it won't run with a Gen 3 mags and it peaked my interest. Nobody has 308 Pmags in stock and I finally found a stack of brand new Gen 3's at a Gun Show today. Brought one home and my SR762 WILL NOT chamber a round from the Gen 3 but functions perfectly with the three Gen 2 mags that came with the gun. I contacted Ruger and Magpul Tech Support with emails this afternoon but obviously haven't received a reply. I took the Gen 3 mag back to the G/S vendor and he refunded the cost and said he intended to contact Magpul as he sold about 80 of the hundred he started with yesterday. He didn't know if any those were for Rugers.

    Monday edit - Just got this response from Ruger..... "If you are having problems with new magazines that you purchased, you can try lubing the magazine with a silicone spray. If this does not resolve the problem please contact Magpul at 1-877-462-4785. Thank you."
     
    Last edited: Dec 12, 2013
  2. Mac11

    Mac11 New Member

    4
    0
    0
    Just got a response from Magpul!


    [FONT=Times New Roman,serif][FONT=Calibri,sans-serif]"Thank you for contacting us. We have heard of some issues popping up with the New SR 7.62 and PMAGs, this is something that we are looking into with Ruger to see if we can find out what’s going on. but as of now we don’t have any answers at to a fix. Please stay in contact with us and Ruger and once we have a fix it will be announced".[/FONT][/FONT]
    [FONT=Times New Roman,serif][FONT=Arial,sans-serif][/FONT][/FONT]
    [FONT=Times New Roman,serif][FONT=Arial,sans-serif]TECH SUPPORT SPECIALIST[/FONT][/FONT]
     

  3. John357

    John357 New Member

    2
    0
    0
    Have had aSR762 for about two weeks, and put 100 rounds thru it without a single malfunction. It came with three Gen 3 mags.