Ruger Talk Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 · (Edited)
My SR556 has about 400 rds through it. No "carrier tilt" just initially wore the finish off the tube lower 1/3 near the pin.
But I discovered a wear point in the receiver, where the charging handle tip rides. The area is about 1/4 " long (depth of wear = 1/64") just aft of a semi circular cut-out.....
I doubt the charge handle tip would have caused this....I'm thinking the cut-out is related to the BCG cam pin movement and the cam pin may be the culprit.....but not a mark on the cam pin.
Any thoughts would be appreciated. I hope the Iphone pix are clear...
 

Attachments

·
Registered
Joined
·
213 Posts
Are you using the stock bolt carrier group?


Sent from my iPhone using Ruger Forum
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #3 ·
Yes, stock BCG & trigger....the charging handle is a Raptor...but nothing on the BCG or charging handle has a mark or wear indicated....I wish I knew what the circular cut, machined opposite the dust cover is....looks like the BCG cam is on the same plain...the wear is just aft of that.


Sent from my iPad using Ruger Forum
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #4 ·
My SR556 has about 400 rds through it. No "carrier tilt" just initially wore the finish off the tube lower 1/3 near the pin.
But I discovered a wear point in the receiver, where the charging handle tip rides. The area is about 1/4 " long (depth of wear = 1/64") just aft of a semi circular cut-out.....
I doubt the charge handle tip would have caused this....I'm thinking the cut-out is related to the BCG cam pin movement and the cam pin may be the culprit.....but not a mark on the cam pin.
Any thoughts would be appreciated. I hope the Iphone pix are clear...
Surprised no one with a SR556 had any concerns....sorry the pix are not the greatest.


Sent from my iPad using Ruger Forum
 
1 - 4 of 4 Posts
Top