New here

Discussion in 'Introductions' started by Nucflash, Apr 9, 2015.

  1. Nucflash

    Nucflash New Member

    1
    0
    0
    Hey Y'all, I'm new here...first post, but maybe I can be of assistance. My SR40C was having the same issues. I did a search and the most popular solution was to clean the Striker channel. There are videos on You tube that show how to do this. Apparently Ruger packs a substantial amount of lube in the channel from the factory. Anyway, I did this and now, approximately 1000 rds later, she runs like a champ.
     
  2. SHOOTER13

    SHOOTER13 RETIRED MODERATOR Lifetime Supporter

    7,454
    16
    38
    Welcome to the R/T !!
     

  3. DoubleR

    DoubleR Active Member

    4,692
    1
    36
    Welcome to the forum:)
     
  4. phideaux

    phideaux Well-Known Member Lifetime Supporter

    12,933
    100
    63
    Welcome to RugerTalk,,

    Thanks for joining.



    Jim
     
  5. havasu

    havasu In the army now..

    5,591
    5
    38
    Welcome to the community!
     
  6. Tommycourt

    Tommycourt Tommycourt

    2,139
    17
    38
    Welcome to one fine forum. Hope you enjoy yourself here.
    Tommy
     
  7. buster40c

    buster40c Well-Known Member

    8,549
    269
    83
    Welcome to the forum. It is a learning experience here with a bunch of good people.

    There are several gun makers that have had problems due to the striker channel being dirty or gummed up from over lube. Some makers make it a point to mention not to over lube the channel and keep it clean.
     
    Last edited: Apr 11, 2015
  8. jmohme

    jmohme Well-Known Member

    1,401
    51
    48
    Welcome and thanks for the tip!